Ninja Trader

NinjaTrader je analytický software pro analýzy trhů. Je nabízen zdarma pro papertrading a backtestování trhů - ideální nástroj pro začínající obchodníky, kteří si potřebují osahat trhy a nechtějí investovat do jiných software. S 30ti denním demo účtem u Zen-Fire poskytuje kvalitní časově nezpožděná ticková data, při paper simuluje i skluzy v plnění a celkově se snaží přiblížit paper trading live obchodování.

Vlastnosti

  • Zobrazování cenových grafů a indikátorů
  • Připojení na různé poskytovatele dat
  • Programovací jazyk NinjaScript (odvozen od C#), možnost doprogramování vlastních indikátorů
  • Nahrávání seance + možnost Playback
  • Možnost zadávání příkazů z DOM nebo přímo z grafu
  • Podporuje ATM - automatické strategie (ke vstupnímu příkazu se zadá SL a PT příkaz)

Obchodní podmínky

  • Pro backtest a papertrade je zdarma včetně ATM strategií
  • Existuje i free verze pro live obchodování, která ovšem neumožňuje použití ATM strategií (poskytují ji svým klientům někteří brokeři)
  • Pro live obchodování včetně ATM je možný pronájem (180$ za 3 měsíce, tedy 60$ měsíčně)
  • Je možné zakoupit za 995$ life-time licenci, která platí i na všechny budoucí verze programu
  • Platbu za life-time je možné rozdělit na 4 měsíční splátky po 299$ (tedy navýšení celkové ceny o 200$)

Demo účet u Zen-Fire

  • Možno žádat na stránkách Zen-Fire (Free Demo)
  • Demo omezeno na 30 dnů
  • po 6ti měsících možno zažádat o další demo (opět 30 dnů)
  • při první registraci si Zen-Fire poznamená vaši IP a MAC adresu (platí od listopad 2009)
  • proto se už nelze zaregistrovat podruhé ze stejného počítače (i když na jinou email adresu) a budete odkázáni na vašeho brokera.

Články zveřejněné zde na finančník.cz

Videotutoriály

Diskuze

Převod NinjaScriptu z verze 6.5 na verzi 7

Další odkazy

Doplňky pro NinjaTrader, indikátory, NinjaScripty

  • BacktestHelper (externí odkaz) - jednoduchý nástroj pro usnadnění přenosu informací (datum, čas, vstup, MAE nebo MFE z grafu) o backtestovaném obchodu do MS Excel, autor: Ladislav Novotný aka Laadiis
    • indikátor “BTH_HLByTR” - zvýraznění premarketu (obecně libovolného časového rámce) (součást balíčku BacktestHelper)
  • VerticalScale, fixuje osu Y v zobrazování grafů
  • TimeHistogram, zobrazuje jak dlouho se vykreslovala usecka na alternativním zobrazení grafu VOLUME, autor Gumphrie & saltminer
  • AAAFinWin, napovídá FinWin patterny ( http://www.financnik.cz/forum/read.php?14,98010,103615#msg-103615 ), autor: uživatel Masaryk
  • RBNextOpenPrice, předpovídá open další úsečky na RB grafech ( http://www.financnik.cz/forum/read.php?4,99000,127227#msg-127227 ), autor: Lucínek
  • tři indikátory od uživatele Brouky & Gordon pro obchodování na RB grafech, všechny tři dostupné zde: http://www.financnik.cz/forum/read.php?14,117270,133376#133376
    • PowerZones, zobrazuje Gordonovy Power zony (a dalsi veci prijemne pro rychle rozhodovani o vstupu do trhu), autor: Brouky
    • RB_Predictor, zobrazuje linky v definovane vzdalenosti od predpokladaneho close posledni svice na RB grafu (je mozne vymalovat az 3 urovne linek v kazdem smeru), autor: Brouky
    • Horizontal, zobrazuje horizontalni linku na presne definovane hodnote (ja si tim treba maluji horizontalni linky na presnych hodnotach do CCI), autor: Brouky

NT - často kladené dotazy FAQ

  • Jak přenést kompletní nastavení NT na jiný počítač, jak zachovat nastavení NT při přeinstalování Windows (Backup)
    • File → Utils → Backup
    • zobrazí se dialogové okno, nechte zaškrtnuté všechno mimo Market replay data
    • Archive - nastavte cestu kam se má vytvořený backup soubor uložit pokud vám nevyhovuje ta defaultní <My Documents>NinjaTrader Backup
    • Stiskněte Run backup
    • vytvořený soubor (*.ntbk) lze pak vzít a prenést na jiný počítač (kde už je nainstalovaný NT) a prenést si tak kompletní nastavení NT (připojení na zdroj dat, workspaces, strategie, indikatory a data pro grafy, ...)
    • obnovení se provede: File → Utils → Restore
  • Načítají se mi jen historická data pro trh YM ale nevykreslují se svíčky tak jak se právě mění cena, grafy jiných trhů se vykreslují správně
    • NT7: Tools → Options → záložka Data → Reset Instruments + restartujte NT
    • NT6: Tools → Options → záložka Misc → Reset Instruments + restartujte NT
 

ninjatrader.txt · Poslední úprava: 17.03.2011 07:28 autor: jiji1
 
Recent changes RSS feed
Upozornění: Všechny informace poskytované na Financnik.cz jsou určeny výhradně ke studijním účelům témat týkajících se obchodování na burze a neslouží v žádném případě coby konkrétní investiční či obchodní doporučení. Provozovatel serveru ani jednotliví autoři nejsou registrovanými brokery či investičním poradcem ani makléřem. Jsou-li na stránkách zmiňovány konkrétní finanční produkty, komodity, akcie, forex či opce, vždy a pouze za účelem studia obchodování na burze. Vydavatel serveru není zodpovědný za konkrétní rozhodnutí jednotlivých uživatelů.

Burzovní obchodování a investování s finančními instrumenty (a komoditami obzvláště) je vysoce rizikové. Rozhodnutí obchodovat komodity a akcie je odpovědností každého jednotlivce a jedině on sám nese za svá rozhodnutí plnou odpovědnost. Nikdy se nepouštějte do obchodů, jejichž podstatě plně nerozumíte. Pamatujte, že burza má svá pravidla, kterým je třeba porozumět, než začnu riskovat své vlastní peníze!

Tento web používá k poskytování služeb a analýze návštěvnosti soubory cookie. Používáním tohoto webu s tím souhlasíte.
Copyright 2016 © Financnik.cz - Developed by BlueCube.cz
Server Financnik.cz vydává a všechny služby provozuje Centrum finančního vzdělávání, s.r.o.
Všechny články zde uveřejněné podléhají autorskému zákonu a jejich kopírování pouze se souhlasem autora.