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Úvod 
Uživatelsky příjemné a multifunkční, integrované, vývojářské prostředí, které je součástí klientského terminálu. MetaEditor IDE se používá 
pro tvorbu, modifikaci a kompilaci zdrojového kódu programů zapsaných v jazyku MetaQuotes Language 4. S programem MetaEditor IDE 
můžete vytvořit funkce Experts Advisors, Custom Indicators a Scripts, které mohou být použity v klientském terminálu k automatizaci 
procesu technických analýz a obchodování na finančních trzích.    

Hlavní vlastnosti programu MetaEditor IDE: 
 Otevírání a ukládání textových souborů; 
 Vyobrazení aktuálně editovaného textu, modifikace a editace řádků; 
 Kopírování a přesun fragmentů textu z jednoho místa na jiné nebo z jednoho dokumentu do druhého;    
 Vytisknutí textů; 
 Vyhledávání kontextů a nahrazení fragmentů textu; 
 Vyobrazení výsledků hledání a nahrazování textových fragmentů jednoduchým způsobem; 
 Použití asistenta; 
 Vyobrazení a používání referencí slovníku  MQL4; 
 Používání různých typů a velkostí fontů; 
 úprava zvýrazňování syntaxí; 
 úprava lišt nástrojů; 
 kontrola syntaxe při kompilaci; 
 nalézání kompilačních chyb pohodlným způsobem; 
 vytváření vykonavatelů programu; 
 náhled na výsledky práce. 
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Otevření MetaEditoru 
MetaEditor můžete otevřít z: 

 klientského terminálu: 
příkazy "Experts -> MetaQuotes Language Editor" z hlavního menu. 

 Z plochy programu Microsoft Windows: 
Kliknutím na ikonku "Start" v liště nástrojů zvolte skupinu obchodního terminálu v menu "Programs" a spusťte "MetaEditor". 
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Vytvoření programu 
Jedním z nejsilnějších atributů klientského terminálu je vytvoření vlastního MQL4 programu. Díky němu můžete kontrolovat obchodní plány 
a vyvíjet vlastní ziskové strategie.  
Jak vytvořit nový Expert Advisor: 

 Klikněte pravým tlačítkem na okno "Navigator" v klientském  terminálu a zvolte položku "Create a new Expert" z context 
menu; 

 Zvolte položky "File -> New" v menu MetaEditoru nebo klikněte na ikonku   v nástrojové liště. Objeví se funkce  Wizard 
pro tvorbu Expert Advisoru. U prvního kroku byste měli specifikovat typ vašeho Advisoru nebo zvolit pro jeho vytvoření 
šablonu. Poté klikněte na volbu "Next" a postupujte podle instrukcí. 

 Expert Advisor 
 Custom Indicator 
 Script 
 Creating Expert Advisor by template 
 Template file format 
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Vytvoření Expert Advisoru 
Jedním z nejsilnějších atributů klientského terminálu je vytvoření vlastní funkce Expert Advisor. Díky ní můžete kontrolovat obchodní plány 
a vyvíjet vlastní ziskové strategie.  
 

K vytvoření Expert Advisoru je třeba specifikovat tyto parametry: 

Name* Pojmenování (souboru) Expert Advisoru  

Author Jméno autora 

Link e-mail nebo webové stránky autora 

Parameters Vstupní parametry (jméno, typ a vstupní hodnota) 

Po specifikování všech potřebných parametrů Expertu klikněte na volbu "Finish" čímž se spustí generování Expertu. 

Výsledkem generování bude zdrojový kód Expert Advisoru s vyjádřením funkcí a parametrů. 
Pozor: Nastavení funkcí a jejich obsahu závisí na výchozí šabloně default "expert.mqt". Více informací o šablonách naleznete v sekci   
Template file format . 
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Vytvoření funkce Custom Indicator 
Jedním z nejsilnějších atributů klientského terminálu je vytvoření vlastní funkce Custom Indicator. Díky ní můžete kontrolovat obchodní 
plány a vyvíjet vlastní ziskové strategie.  
U prvního kroku byste měli specifikovat pojmenování nové funkce Custom Indicator, jméno autora a jeho e-mailovou adresu, stejně tak 
jméno, typ a vstupní hodnotu funkce custom parameters. Poté klikněte na volbu "Next". 



U druhého kroku specifikujte tyto generační parametry: 
 
Indicator in a Separate Window Vykreslení indikátoru v samostatném okně 

Minimum Nastavení pevného spodního ohraničení okna indikátoru. Hodnota musí být 
alespoň o jeden bod nižší než  maximum 

Maximum Nastavení pevného vrchního ohraničení okna indikátoru. Hodnota musí být alespoň 
o jeden bod vyšší než minimum 

Indexes Indexové seskupení pro vyobrazení v okně indikátoru 

Po zadání potřebných parametrů funkce Custom Indicator klikněte na volbu "Finish", čímž se spustí generování zdrojového kódu funkce  
Custom Indicator . 
Výsledkem generování bude zdrojový kód funkce Custom Indicator s vyjádřením jejích funkcí a parametrů  
 
Pozor: Nastavení funkcí a jejich obsahu závisí na výchozí šabloně default "indicator.mqt". Více informací o šablonách naleznete v sekci   
Template file format . 
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Vytvoření skriptů 

Jedním z nejsilnějších atributů klientského terminálu je vytvoření vlastních skriptů. Díky ní můžete kontrolovat obchodní plány a vyvíjet 
vlastní ziskové strategie. K vytvoření skriptů je třeba zadat parametry pro generování: 

Name* Jméno skriptu (souboru) 

Author Jméno autora 

Link e-mail nebo webové adresy autora 

Parameters Vstupní parametry (jméno, typ a vstupní hodnota) 

Po zadání potřebných parametrů funkce Custom Indicator klikněte na volbu "Finish", čímž se spustí generování skriptu. 

Výsledkem generování bude zdrojový kód funkce Scripts s vyjádřením jejích funkcí a parametrů. 
Pozor: Nastavení funkcí a jejich obsahu závisí na výchozí šabloně default "script.mqt". Více informací o šablonách naleznete v sekci   
Template file format . 
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Vytvoření funkce Expert Advisor pomocí šablony 
Při zapisování Expert Advisorů je často potřeba vytvořit několik Expert Advisorů se stejným zdrojovým kódem. K vyřešení problému s tímto 
spojeného můžete použít metodu šablon, která vám umožní automatizaci vývoje funkce.    

Pokud se rozhodnete pro generování šablony, měli byste zvolit šablonu ze seznamu. Další fáze generování závisí na zvoleném typu šablony.   
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Formát souboru šablony 
Soubor šablony je textový soubor obsahující popis generovacích parametrů a parametrů  MQL4 se zvláštními generovacími příkazy.   
Soubory šablon mají příponu *.mqt a jsou umístěny ve složce install_path\experts\templates. 

Generovací parametry 

Popis generovacích a vstupních parametrů pro indikátory je obsažen pod označením  <expert> a </expert> . Popis vstupních 
parametrů pro funkci init() je obsažen pod s označením  <param> a </param> . Popis indikátoru je uveden pod označením  <ind> a 
</ind>. 

Proměnné pro generování funkce Experts Advisor: 

Type Typ Expert Advisoru. Možné hodnoty jsou EXPERT, INDICATOR, SCRIPT 

separate_window Vykreslení indikátoru ve zvláštním okně 

ind_minimum Nastavení pevného spodního ohraničení okna indikátoru 

ind_maximum Nastavení pevného horního ohraničení okna indikátoru 

Promměnné pro vstupní parametry: 
Type Typ parametru 
Name Pojmenování parametru 
Value Default hodnota 

Proměnné indikátoru 

Type Typ vyobrazení indikátoru. Možné hodnoty jsou DRAW_LINE, DRAW_HISTOGRAM, DRAW_SECTION, 
DRAW_ARROW 

Color Barva indikátoru 
Arrow Znak pro vyobrazení indikátoru DRAW_ARROW . "Wingdings" font se používá pro vyobrazování znaků    

Příkazy pro generování 

Po bloku s generovacími parametry program MQL4, který obsahuje generovací příkazy, musí být následován v souboru šablony.   

Generovací příkazy: 
#header# Záhlaví programu (komentář se jménem souboru, jméno a odkazy autora) 
#link# Webová adresa vaší společnosti. 
#copyright# Jméno vaší společnosti. 
#init# Definování funkcí se všemi parametry init 
#globals# Vyjádření globálních proměnných 
#indicators# Parametry indikátoru 
#globals_init# Inicializace globálních proměnných  
#indicators_init# Inicializace indikátorů 

Příklad šablony indikátoru - Accelerator.mqt 
 
<expert> 
type=1 
separate_window=1 
<ind> 
color=Green 
type=DRAW_HISTOGRAM 
</ind> 
<ind> 
color=Red 
type=DRAW_HISTOGRAM 
</ind> 



</expert> 
#header# 
#define   copyright "#copyright#" 
#define   link      "#link#" 
 
#indicators# 
 
//+------------------------------------------------------------------+ 
//| Custom indicator initialization function                         | 
//+------------------------------------------------------------------+ 
int init() 
  { 
   //---- 2 pro výpočet se použijí dvě dodatečné vyrovnávací paměti. 
   IndBuffersUsed(4); 
   //---- vykreslení nastavení 
   #indicators_init# 
   SetIndexDigits(6); 
   SetIndexDrawBegin(0,38); 
   SetIndexDrawBegin(1,38); 
   //---- jméno pro označení DataWindow a indicator subwindow 
   IndicatorShortName("AC"); 
   //---- inicializace provedena 
   return(0); 
  } 
//+------------------------------------------------------------------+ 
//| Accelerator/Decelerator Oscillator                               | 
//+------------------------------------------------------------------+ 
int start() 
  { 
   int    limit; 
   int    counted_bars=IndicatorCounted(); 
   double prev,current; 
   //---- kontrola možných chyb 
   if(counted_bars<0) return(-1); 
   //---- naposledy propočítána svíce bude přepočítána 
   if(counted_bars>0) counted_bars--; 
   limit=Bars-counted_bars; 
   //---- macd přepočítán v první vyrovnávací paměti 
   for(int i=0; i<limit; i++) 
      SetIndexValue(2,i,iMA(NULL,0,5,0,MODE_SMA,PRICE_MEDIAN,i)-
iMA(NULL,0,34,0,MODE_SMA,PRICE_MEDIAN,i)); 
   //---- signální linie je propočítána druhou vyrovnávací pamětí 
   for(i=0; i<limit; i++) 
      SetIndexValue(3,i,iMAOnBuffer(2,Bars,5,0,MODE_SMA,i)); 
   //---- odeslání hodnot mezi oběmi vyrovnávacími paměťmi 
   bool up=true; 
   for(i=limit-1; i>=0; i--) 
     { 
      current=GetIndexValue(2,i)-GetIndexValue(3,i); 
      prev=GetIndexValue(2,i+1)-GetIndexValue(3,i+1); 
      if(current>prev) up=true; 
      if(current<prev) up=false; 
      if(!up) 
        { 
         SetIndexValue(1,i,current); 
         SetIndexValue(0,i,0.0); 
        } 
      else 
        { 
         SetIndexValue(0,i,current); 
         SetIndexValue(1,i,0.0); 
        } 
     } 
   //---- hotovo 



   return(0); 
  } 
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Modifikace programu 
K modifikaci zdrojového kódu funkce Expert Advisor zapsané v jazyku MQL4 byste měli provést jeden z následujících úkonů: 

 Pravým tlačítkem klikněte na jméno Expert Advisoru zvoleného v liště Common tab v okně Navigator window v klientském 
terminálu k otevření context menu a zvolte “Modify item”. 

Pozor: Můžete přepnout zpět do klientského terminálu z menu "Tools -> Trading Terminal" nebo kliknutím na ikonku 

 v nástrojové liště nebo klávesou "F4".  

 Otevřete dialogové okno "Open" ve funkci MetaEditor buď zvolením z menu "File -> Open" nebo ikonkou   v nástrojové 
liště. Zvolte požadovaný zdrojový soubor Expert Advisoru s příponou "mq4". Funkce Expert Advisor jsou umístěny ve složce 
"Experts" v klientském terminálu. Klikněte na jméno Expert Advisoru, který plánujete editovat a poté na volbu "Open". 

 Pokud je okno "Navigator" v MetaEditoru zavřené, otevřete  jej prostřednictvím okna “Files", zvolte soubor Expert Advisoru a 
dvakrát klikněte. Okno "Navigator" vyobrazí soubory a složky umístěné ve složce "Experts" klientského terminálu. 

Poté je soubor Expert Advisoru otevřen v MetaEditoru a vy můžete editovat jeho zdrojový kód.    
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Uložení programu 
MetaEditor umožňuje uložení vytvořeného nebo modifikovaného programu. K uložení Advisoru zvolte z menu "File -> Save" nebo klikněte 

na ikonku  v nástrojové liště. K uložení zdrojového kódu všech otevřených programů zvolte v menu "File -> Save All". K uložení 
programu pod jiným jménem zvolte v menu "File -> Save As", vložte nové jméno do pole "Name" v boxu dialogu "Save As" a klikněte na 
"OK". 
Pozor: MetaEditor umožňuje ukládání zdrojového souboru Advisoru ve formátu HTML. K tomu zvolte v menu "File - Save As" a uložte typ 
"Type" v poli dialogového boxu "Save As" do souborů HTML ("*.htm;*.html"). 
Doporučujeme ukládání programů pod stejnými jmény . 
Programový zdrojový kód by měl být uložen před kompilací.  
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Vytištění programu 
MetaEditor může vytisknout zdrojový kód programu. Pro vytištění programu: 

 Přepněte do okna se zdrojovým kódem, který má být vytištěn; 

 Zvolte v menu "File -> Print" nebo klikněte na ikonku   v nástrojové liště; 
 Specifikujte nastavení tisku: tiskárnu as počet kopií; 

Výchozím nastavením orientace je portrét.  Změnit to můžete v dialogovém oknu "Properties"; 
 K vytištění zdrojového kódu do souboru zakřížkujte "Print to file";  
 Klikněte na potvrzení "OK". 

Poté bude program zdrojového kódu odeslán do tiskárny. Pokud zvolíte "Print to file" mode, vyobrazí se dialogový box "Print to file", kde 
můžete uvést jméno souboru, do kterého si přejete program uložit. Soubor bude mít  příponu "*.prn". Před vytištěním souboru můžete 
vyobrazit náhled obsahu funkce MetaEditor v aktivním okně. Totéž je možné provést u klientského terminálu.    

K vytvoření náhledu na stránku tisku je třeba: 



 Zvolit v menu "File -> Print Preview". 
Náhled se vyobrazí v okně. Pokud se do okna nevejde, můžete stránkou “rolovat” k prohlédnutí celého náhledu; 

 Pokud náhled sestává z více než jedné stránky, můžete jimi procházet pomocí voleb "Next Page" a "Previous Page". K 
vyobrazení dvou stránek najednou klikněte na symbol "Two Pages"; 

 Pro příbližení/vzdálení objektu použijte symboly "Zoom In" / "Zoom Out". Vyskytují se zde tři možnosti přiblížení; 
 K vytištění dalšího textu klikněte na  "Print"; 
 K uzavření okna náhledu použijte symbol "Close". 
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Opuštění funkce MetaEditor 
K opuštění funkce MetaEditor zvolte v menu položku "File -> Exit".  Po opuštění programu vám program nabídne možnost k uložení a 
otevření modifikovaného programu. 
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Editace textu 
V aktivním okně funkce MetaEditor můžete text vyjmout, vkládat, kopírovat a přesunovat. Tyto funkce můžete rovněž použít, pokud chcete 
vložit text zapsaný v MQL4 do jiných aplikací (např. MS Word) a naopak.   
Pro zkopírování textu: 

 Zvolte text, který chcete zkopírovat. K volbě celého textu aktivního okna použijte položku "Edit -> Select All"; 

 Zvolte položku "Edit -> Copy" v menu nebo ikonku  v nástrojové liště pro zkopírování textu do přechodné paměti. 
Totéž učiníte volbou položky "Copy" v “context menu”; 

 Vyberte místo, kam chcete text vložit; 

 V menu zvolte položku "Edit -> Paste" nebo ikonku  v nástrojové liště k přesunu textu do aktivního okna. Pokud jej 
přesunete do jiné aplikace. Postupujte podle pokynů v dané aplikaci. Text můžete rovněž přesunout pomocí položky "Paste" 
v context menu. 

Vyjmutí textu: 
 Zvolte text, který chcete vyjmout; 

K volbě celého textu aktivního okna použijte položku "Edit -> Select All"; 

 K vyjmutí zvoleného textu použijte položku "Edit -> Cut" v menu nebo ikonku v nástrojové liště. 
 
Můžete ji rovněž vyjmout příkazem "Cut" z context menu. 
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Operace “vpřed” a “zpět” 
Nedokončené operace můžete během editace posunout o krok zpět nebo vpřed. Operaci zpět můžete vykonat např. při chybném smazání 
textu v MQL4 text. 

K posunu operace o krok zpět zvolte položku "Edit -> Undo" z menu nebo klikněte na ikonku  v nástrojové liště. 

K posunu operace o krok vpřed zvolte položku "Edit -> Redo" z menu nebo klikněte na ikonku  v nástrojové liště. 
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Vyhledávání textu 
MetaEditor má v menu položku pro vyhledávání textového řetězce prostřednictvím zdrojového kódu programu aktuálně otevřeného v 
aktivním okně.  
K vyhledání textu ve zdrojovém kódu: 

 Otevřete zdrojový kód programu, ve kterém hodláte vyhledávat;  
 Umístěte kurzor do místa, od kterého chcete vyhledávat; 

 Zvolte z menu položku "Edit -> Find" nebo ikonku  v liště nástrojů k otevření dialogového boxu  "Find" ; 
 Vložte text, který chcete vyhledat, v dialogovém boxu "Find"; 
 Zadejte směr vyhledávání prostřednictvím políček "Up" a "Down" ve skupině "Direction". Vyhledávání bude spuštěno z 

určeného místa v odpovídajícím směru a pokrývá celý text;   
 K nalezení celého slova zakřížkujte "Match whole word only"; 
 K volbě case-sensitive zakřížkujte "Match Case". V tom případě bude text vyhledáván až po dosažení specifikovaného řetězce 

v poli "Find what" kde je uveden odpovídající případ; 
 Ke spuštění nebo pokračování vyhledávání použijte volbu "Find Next". Nalezený řetězec je zvýrazněn; 
 K zastavení vyhledávání použijte položku "Cancel". 

Pozor: MetaEditor ukládá poslední nastavení parametrů vyhledávání, takže je můžete použít znovu i po uzavření dialogového boxu  "Find". 
Ke spuštění dalšího vyhledávání podle posledních parametrů použijte položku "Edit -> Find Next" z menu nebo klávesu "F3". K vyhledání 
předchozí položky podle posledních parametrů zvolte z menu položku "Edit - Find Previous" nebo kombinaci kláves "Shift+F3". 
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Vyhledání a nahrazení textu 
MetaEditor obsahuje příkaz pro vyhledání textového řetězce ve zdrojovém kódu a jeho nahrazení jiným. K vyhledání a nahrazení textu: 

1. Otevřete Advisor, ve kterém hodláte vyhledávat a modifikovat; 
2. Umístěte kurzor do místa, ze kterého chcete hledat; 

3. V menu zvolte položku "Edit -> Replace" nebo ikonku  v nástrojové liště k otevření dialogového boxu "Replace"; 
4. Zadejte text, který chcete vyhledat, do pole "Find what"; 
5. Vložte textový řetězec, který chcete nahradit do pole "Replace with"; 
6. Zadejte směr vyhledávání prostřednictvím políček "Up" a "Down" ve skupině "Direction". Vyhledávání bude spuštěno z 

určeného místa v odpovídajícím směru a pokrývá celý text;   
7. K nalezení celého slova zakřížkujte "Match whole word only"; 
8 K nalezení celého slova zakřížkujte "Match whole word only"; 
9. K volbě case-sensitive zakřížkujte "Match Case". V tom případě bude text vyhledáván až po dosažení specifikovaného řetězce 

v poli "Find what" kde je uveden odpovídající  případ  
9 Ke spuštění nebo pokračování vyhledávání použijte volbu "Find Next". Nalezený řetězec je zvýrazněn; 
10 Klikněte na položku "Replace" k nahrazení zvýrazněného textu textem novým; 
11 Opakujte všechny kroky až do vyhledání a nahrazení všech fragmentů textu, které potřebujete nahradit.    

Pozor: Pokud kód Advisoru obsahuje více řetězců uvedených v poli "Find what", můžete je nahradit všechny najednou pomocí položky 
"Replace All". 
 
 
  

 Vyhledávání souborů pro text – Editování programu       
 

  

Vyhledávání souborů pro text 
  

MetaEditor obsahuje příkaz pro vyhledávání souborů pro spcifikovaný textový řetězec. 
K vyhledání souborů pro určitý text: 

 Z menu zvolte položku "Edit - Find in Files" nebo ikonku  v liště nástrojů k otevření dialogového boxu "Find in Files" ; 
 Vložte text, který chcete vyhledat, v poli "Find what" ; 
 Zadejte typy souborů k vyhledání do pole "In files/file types". Můžete je zadat buď ze seznamu “drop-down” nebo je vepsat 

ručně; 
 Použijte pole "In folder" k zadání cesty ke složce, ve které má být provedeno vyhledávání. Cestu můžete změnit pomocí 

položky "Browse" nebo otevřením dialogového boxu "Choose Directory"; 
 K nalezení celého slova zakřížkujte "Match whole word only"; 
 K volbě  case-sensitive zakřížkujte "Match Case". V tom případě bude text vyhledáván až po dosažení specifikovaného 

řetězce v poli "Find what" kde je uveden odpovídající  případ; 
 K vyhledání zvláštních znakových sekvencí a šablon nazývaných “regular expressions” zakřížkujte  pole "Regular 

expressions"; 
 K vyhledávání podsložek zakřížkujte pole "Look in subfolders"; 
 Ke spuštění vyhledávání použijte položku "Find", ke zrušení položku  "Cancel". 

Výsledky vyhledávání naleznete v tabulce "Find in Files" v okně "Toolbox". Pro více informací viz. sekce Viewing the result of search in 
files   
Pozor: Pokud nebyly nalezeny odpovídající výrazy, v tabulce "Find in Files" žádná data nenaleznete 
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Textové záložky 
MetaEditor má nástroj pro označení určitých textových řetězců během editace programu. Tento nástroj zvýrazňuje textové řetězce 
umístěním žluté vlaječky do zvoleného pole. Toto označení se nazývá záložka  (bookmark). Záložky, zůstanou viditelné až do doby, než je 
vymažete.  
Označení textového řetězce: 

 Umístěte kurzor do textové řady, kterou chcete označit; 
 V menu zvolte položku "Edit -> Bookmarks -> Toggle Bookmark" nebo kombinaci kláves "Ctrl+F2". 

Odstranění záložky: 
 Umístěte kurzor do textové řady obsahující záložky, kterou se chystáte smazat; 
 V menu zvolte položku "Edit -> Bookmarks -> Toggle Bookmark" nebo kombinaci kláves "Ctrl+F2". 

Pro přesun kurzoru k další záložce zvolte z menu položku "Edit -> Bookmarks -> Next Bookmark" nebo klávesu "F2". K přesunu kurzoru do 
předchozí záložky zvolte z menu položku "Edit -> Bookmarks -> Previous Bookmark" nebo kombinaci kláves"Shift+F2". K odstranění všech 
záložek zvolte z menu položku "Edit -> Bookmarks -> Clear All Bookmarks" nebo kombinaci kláves "Shift+Ctrl+F2". 
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Asistent 
Asistent usnadňuje zapisování textu v Advisoru. Automaticky vyobrazuje seznam "List Names" po vložení několika prvních znaků jména 
objektu vyjádřeného v MQL4. Počet znaků je uveden v poli "List Names after" a v tabulce "General" dialogového boxu "Options". U 
výchozího nastavení je hodnota "List Names after" 5. Po zvolení požadovaného jména ze seznamu dvojklikem odklikněte nebo stiskněte 
klávesu "Enter" a asistent doplní nedokončené jméno. Pokud není zaškrtnuto pole "Auto List Names", musíte vyobrazit seznam z položky v 
menu  "Edit -> List Names". 

Asistent automaticky vyobrazuje pomocný nástroj "Parameter Info" po zadání levé závorky po vyplnění jména funkce. Tento pomocný 
nástroj obsahuje seznam funkčních parametrů objektu a aktuální parametr je vyobrazen tučným písmem. Pokud není zaškrtnuta volba 
"Auto Parameter Info", musíte k vyobrazení pomocného nástroje použít položku z menu "Edit -> Parameter Info". 

Více informací o konfiguraci asistentu naleznete v sekci Common options . 
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Kompilování programu 
Program v jazyku MQL4 je kombinací jednoduchých slov, operátorů a pravidel syntaxí, používaných ke generování příkazů, které používá 
klientský terminál pro řešení jednoho nebo více obchodních zadání. V průběhu kompilace probíhá kontrola chyb zdrojového textu. Pokud 
jsou nalezeny chybné syntaxe, vyobrazí se odpovídající chybové hlášení v tabulce "Errors" nástrojového okna "Toolbox" sloužícího k další 
analýze. 

Ke kompilování programu zvolte z menu položku , select the "File -> Verify" nebo klikněte na ikonku  v liště nástrojů. 
Pozor: Program můžete také kompilovat prostřednictvím položky z context menu "Verify" nebo klávesou "F5".  

Pokud je kompilace úspěšná, program je uložen. Pokud MetaEditor detekuje chybu, vyobrazí se chybové hlášení v tabulce "Errors". Pokud 
nejsou během kompilace odhaleny žádné chyby, vyobrazí se nápis “Verified- 0 error(s), 0 warnings". 
 
Více informací naleznete v sekci Viewing error messages. 
 



 
  

 Ovládání oken – Kontrola oken       
 

  

Ovládání oken 
MetaEditor vyobrazuje text každého programu v odděleném okně. Můžete otevřít několik oken najednou. 

Okna můžete aktivovat, měnit jejich velikost, přesunovat, maximalizovat, obnovovat, minimalizovat a upravovat.  

Aktivování oken 
Navzdory faktu, že můžete otevřít několik oken najednou, pouze jedno okno může být v daný moment aktivováno. Toto je důležité vědět, 
neboť lišty nástrojů a položky menu se většinou vztahují k právě aktivovanému oknu. Proto je před prováděním jakýchkoliv úkonů v textu 
nutné okno aktivovat. K tomu je třeba kliknout na jakoukoliv část okna nebo jeho titulu v menu  "Window". Po aktivaci okna se barva jeho 
titulu změní.  

Změna velikosti okna 
Touto funkcí můžete změnit velikost a tvar okna. Ke změně velikosti pohněte ukazatelem myši k rohům okna. Ten se změní ve 
dvoustrannou šipku. Pro horizontální změnu pohněte ukazatelem do stran, přidržte levé tlačítko, přesuňte okno do požadované šířky a 
uvolněte tlačítko. Pro změnu vertikální zachyťte okno v horní nebo spodní části, přesuňte do požadované výšky obdobným způsobem a 
uvolněte tlačítko. Pro změnu jak horizontální, tak vertikální, zachyťte okno v rozích a roztáhněte do požadované velikosti.    

Přesun oken 
Pro přesun okna: 

 Přesuňte ukazatel na jeho titul; 
 Stiskněte a přidržte levé tlačítko myši; 
 Přesuňte okno do nové pozice; 
 Uvolněte tlačítko myši. 

Maximalizace, Obnovování a Minimalizace oken 
Když vytvoříte okno, vyobrazí se ve výchozím nastavení; můžete jej minimalizovat, maximalizovat nebo obnovovat.  

Když maximalizujete okno, změní se jeho velikost do vyobrazení v plném okně. Jméno a nástrojová lišta zůstanou, titul je však zakrytý. Ve 
skutečnosti maximalizujete prostor, který je pro vyobrazení okna vymezen. K maximalizaci okna použijte v titulní liště položku     
"Maximize" ve stavu normálního nebo minimalizovaného okna. 

Pokud okno obnovujete, obnovíte jeho předchozí stav. Opětovným kliknutím na položku "Restore" obnovíte jeho normální stav. 

Při minimalizaci je okno staženo do své malé lišty. Okno zůstává nadále otevřené, ale nezabírá místo na obrazovce. K minimalizaci okna 
editoru zvolte položku "Minimize" na pravé straně lišty. 

Úprava oken 
K úpravě oken použijte odpovídající příkazy z menu "Window". Můžete z nich vytvořit kaskádu, horizontálně nebo vertikálně je překrývat 
jedno přes druhé.  

K horizontálnímu překrývání zvolte z menu položku "Window -> Tile Horizontally". K vertikálnímu překrytí zvolte z menu položku  "Window 
-> Tile Vertically" . K volbě kaskády použijte položku "Window -> Cascade". V tomto případě se aktovní okno umístí nad všechny ostatní. 
Barva titulní lišty aktivního okna se od ostatních odlišuje. Sestavení oken tímto způsobem je pohodlné, protože okna tak mají stejnou 
velikost, je k nim dobrý přístup a všechna jsou viditelná.   
Pozor: Položky z menu "Window -> Tile Vertically", "Window -> Tile Horizontally" a "Window -> Cascade" nemění stav minimalizovaných 
oken. Pouze jsou přemístěny do spodní části pod otevřená okna.  

Pokud jsou minimalizována všechna okna, můžete je upravovat ve spodní části prostřednictvím příkazu  “Arrange Icons". Titulní lišta 
aktivního okna má vždy odlišnou barvu. K uzavření všech oken použijte příkaz   "Window -> Close All" z menu. 
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Nástrojová lišta 
Je vyobrazena ve výchozím nastavení. K přepínání jejího vyobrazení zvolte z menu položku "View -> Toolbar". 
Pozor: 
Pokud je vyobrazena stavová lišta, vyobrazuje tato informaci o provádění akce při přesunu ukazatele na příkaz "Toolbar". 

Více informací naleznete v sekci Toolbar settings. 
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Stavová lišta 
Stavová lišta je oblast ve spodní části hlavního okna MetaEditoru. Vyobrazuje zprávy o aktuálním stavu dokumentů, případně jiné 
informace, týkající se např. popisu příkazů nebo voleb.   

K přepínání vyobrazování stavové lišty zvolte z menu "View -> Status Bar". 

Pozor: 
Pokud je vyobrazena stavová lišta, informace jsou vyobrazeny při přesunu ukazatele do příkazu "Status Bar". 
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Používání okna Toolbox 
V okně "Toolbox" ve funkci MetaEditor má tři tabulky: "Errors", "Find in Files" a "Help". 

Tabulka "Errors" vyobrazuje všechny zprávy, týkající se chyb detekovaných v průběhu kompilace Pokud dvakrát kliknete na řádek “error 
message”, kurzor je přemístěn na chybu v textu a označen zvláštním znakem v poli “special margin”. Tato funkce vám pomůže rychle a 
snadno vyhledat jakoukoliv chybu. Pokud z menu zvolíte  "Edit -> Find in files", tabulka "Find in Files" vyobrazí seznam souborů a řádků 
obsažených v nalezeném textu. Po dvojitém kliknutí na řádek v tomto seznamu se otevře odpovídající soubor (pokud již není otevřen), 
kurzor je přesunut do nalezeného textu a řádek je označen zvláštním znakem. Tato funkce vám umožní nalézt snadno a rychle jakýkoliv 
text. Tabulka "Help" vyobrazuje doplňkové informace o objektech programu MQL4 ve stromu okna "Dictionary". 

Okno "Toolbox" je plovoucím oknem a může být přesunuto v rámci MetaEditoru kamkoliv. Ve výchozím nastavení je okno otevřeno ve 

spodní části. K otevření okna "Toolbox" zvolte z menu položku "View -> Toolbox" nebo ikonku  v liště nástrojů. K uzavření okna buď 
proveďte totéž nebo klikněte na ikonku   v titulní liště. 
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Vyobrazení chybových zpráv 
Pokaždé, když MetaEditor nalezne chybu během kompilačního procesu, vyobrazí odpovídající zprávu v automaticky otevřené tabulce   
"Errors" okna "Toolbox". Chybová hlášení kompilace obsahují jméno souboru Advisoru, umístění chyby v Advisoru, její popis a typ.  

Tabulka "Errors" až do detekování chyby v kompilaci zůstává prázdná. Pro otevření tabulky "Errors" a označení kompilační chyby v textu 
Advisoru je třeba: 

 Klikněte na tabulku "Errors". Pokud je okno "Toolbox" uzavřeno, je třeba nejprve zvolit položku z menu "View -> Toolbox" 

nebo ikonku  v nástrojové liště; 
 Klikněte dvakrát na řádek s chybovou zprávou, kterou potřebujete. Pokud je okno s nalezenou chybou uzavřeno, tímto 

úkonem dojde k jeho otevření. Okno Advisoru se stane aktivním. Kurzor se přesune před text, kde se chyba vyskytla a řádek 
obsahující kompilační chybu je označen zvláštním znakem (stop znak) ve zvoleném poli. Můžete rovněž kliknout pravým 
tlačítkem myši na chybovou zprávu a zvolit z context menu příkaz “Go To". Použijte klávesy "F8"/"Shift-F8" k přesunu do 
následující/předchozí chyby.  

Pozor:  

1. Pokud je kompilace úspěšná, žádná chybová hlášení v tabulce "Errors" nenaleznete; 

2. Všechna chybová hlášení v tabulce "Errors" můžete odstranit kliknutím pravého tlačítka myši kdekoliv v prostoru tabulky a 
zvolením příkazu  "Clear" v context menu. Můžete automaticky upravit rozměr sloupců kliknutím pravého tlačítka myši a 
zvolením příkazu "Auto Arrange" z context menu. 
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Vyobrazování výsledků vyhledávání souborů 
Výsledky vyhledávání souborů naleznete v tabulce "Find in Files" okna "Toolbox". Pokud je okno "Toolbox" zavřené, zvolte z menu položku  

"View -> Toolbox" nebo ikonku  v liště nástrojů a otevřete jej. 

Pokud dvakrát kliknete na řádek s výsledkem vyhledávání v tabulce "Find in Files", vyobrazí se odpovídající soubor s nalezeným textem. 
Kurzor se přesune na začátek textu a řádek bude označen zvláštním znakem – zelenou šipkou. Můžete rovněž kliknout pravým tlačítkem 
myši v dané volbě a zvolit z context menu příkaz  "Go To". 
Pozor: 
 Tabulku "Find in Files" můžete vyprázdnit kliknutím pravého tlačítka myši a zvolením příkazu "Clear" z context menu. Můžete rovněž 
automaticky upravit velikost sloupců kliknutím pravého tlačítka myši a zvolením položky "Auto Arrange" z context menu. 
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MQL4 – reference slovníku 
Reference slovníku MQL4 jsou vyobrazeny v tabulce  "Help" okna "Toolbox". Pokud je okno "Toolbox" uzavřeno,k otevření použijte položku  

"View->Toolbox" z menu nebo klikněte na ikonku  v liště nástrojů. 

K vyobrazení referencí: 

 Zvolte z menu "View->Navigator" nebo ikonku   k otevření okna"Navigator". 
 Zvolte tabulku "Dictionary". 
 Použijte strom tabulky "Dictionary" k vyhledání odkazu na potřebné informace. 
 Dvakrát klikněte na odkaz. Vyobrazí se tabulka "Help" okna "Toolbox" s referencemi. 
 Umístěte kurzor na požadované slovo (funkci nebo jméno proměnné) v textu programu a stiskněte <Ctrl>+<F1> 

Poznámka: Tabulku "Help" můžete použít bez otevření okna "Dictionary". K tomu je třeba: 

 Zvolit z menu položku "View - Toolbox" nebo ikonku  v liště nástrojů k otevření okna "Toolbox". 
 Přepnutí do tabulky "Help". 
 Nalezení odkazu na požadovanou informaci ve stromu tabulky "Help". Pokud tabulka "Help" reference nezobrazí, klikněte na 

ikonku  v liště nástrojů tabulky "Help" a vyhledejte požadovaný odkaz. 
 Klikněte na odkaz pro vyhledání referencí. 

 Klikněte na ikonku   k přesunu do dalšího tématu. Klikněte na ikonku   k přesunu do předchozího 
tématu. 

 Pro synchronizaci referencí se stromem slovníku klikněte na ikonku  . 

Poznámka:   Pro navigaci mezi navštívenými stránkami tabulky  Help můžete použít ikonky  a . 
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Používání okna Navigator 
Okno "Navigator" v MetaEditoru obsahuje 2 tabulky: "Files" a "Dictionary". 

Tabulka "Files" vyobrazuje MQL4 soubory a složky  z adresáře "experts/" klientského terminálu. Dvojitým kliknutím na řádek se jménem 
souboru otevřete soubor pro editaci.  

Tabulka "Dictionary" vyobrazuje strukturu referencí  MQL4 jazyka. 

Okno "Navigator" je plovoucím okně, které může být umístěno kdekoliv v MetaEditoru. Ve výchozím nastavení se otevírá vpravo. K otevření 

okna "Navigator" zvolte položku "View->Navigator" z menu nebo ikonku  v liště nástrojů. Pro uzavření okna učiňte totéž nebo klikněte 
na ikonku   na pravé straně titulní lišty. 
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MQL4 slovník 
MQL4 slovník obsahuje odkazy na informace o objektech MQL4 používaných v MetaEditoru. MQL4 slovník je organizovaný formou stromu, 
takže je jednoduché nalézt jakýkoliv objekt. Slovník obsahuje odkazy na doplňkové informace a internetové stránky. Při dvojitém kliknutí na 
odkaz se vyobrazí v tabulce “Help" okna "Toolbox" požadovaná informace. 

K vyobrazení referencí: 

 Zvolte z menu položku "Tools->Navigator" nebo klikněte na ikonku   v liště nástrojů, čímž otevřete plovoucí okno  
"Navigator". 

 Přepněte do tabulky "Dictionary". 
 Vyhledejte potřebný odkaz ve stromu tabulky "Dictionary". 
 Klikněte na element v indexu pro otevření referenčního odkazu. Seznam se vyobrazí rovněž v tabulce "Help". 
 Zvolte odkaz ze seznamu. Uvidíte tak veškeré informace související s odkazem . 
 Použijte funkci "Drag&Drop" ke vložení MQL4 objektu označeného ikonkou   do textu. 

Pozor: 
Techniku "Drag&Drop" (přetáhnout a upustit) můžete použít ke vložení jakéhokoliv textu z tabulky "Help" do Advisoru. 

Více informací naleznete v sekci MQL4 dictionary reference.  
 
 
 
 
  

 Práce se soubory – Okno Navigator       
 

  

Práce se soubory 
Soubor navigátoru vyobrazí seznam MQL4 souborů a složek umístěných v podsložce "Experts" klientského terminálu. Soubor navigátoru je 
organizován formou stromu, takže v něm snadno naleznete a otevřete požadovaný soubor pro editaci. V context menu můžete použít tyto 
položky:   

 "New File..." vytvoření nového souboru v aktuálním adresáři. 
 "New Folder..." vytvoření nové složky. 
 "Open" otevření souboru pro editaci. 
 "Delete" odstranění souboru nebo složky. 
 "Refresh" obnovení seznamu souborů ve složce. 

Okno navigátoru vyobrazí následující standardní složky: 
 Složka "files" obsahuje složky a soubory dostupné v Expertech, Indikátorech a Skriptech.   
 Složka “include" obsahuje přiložené příkazy pro přístup ke složkám programů - #include <file_name.h>. 
 Složka"indicators" obsahuje uživatelské indikátory - custom indicators. 
 Složka "library" obsahuje moduly sdílených knihoven. 
 Složka "logs" obsahuje soubory pro zalogování expertů, uživatelských indikátorů a skript. 
 Složka "scripts" obsahuje uživatelské skripty. 
 Složka "templates" obsahuje šablony pro generování expertů, indikátorů a skript ve funkci “Advisor Creation Wizard”. 

Soubory pro funkci Expert Advisor jsou umístěny v kořenu stromu navigátoru. 

Pro otevření okna navigátoru: 

 Z menu zvolte položku "Tools -> Navigator" nebo ikonku  v liště nástrojů plovoucího okna "Navigator"; 
 Přepněte do tabulky "Files". Ta obsahuje seznam souborů a složek; 
 Dvojitým kliknutím otevřete položku pro otevření ve stromu k editaci. 

 
 



 
  

 Vyhledávání ve slovníku – Okno Navigator       
 

  

Vyhledávání ve slovníku 
Tabulka “dictionary search” je pohodlný, nástrojem k vyhledání informací ve slovníku pomocí klíčových slov. 

K otevření vyhledávání ze slovníku: 

 Zvolte v menu položku "Tools -> Navigator" nebo ikonku  v nástrojové liště k otevření okna "Navigator". 
 Přepněte do tabulky "Search". 
 Vložte klíčové slovo nebo frázi do vstupního pole. 
 Klikněte na volbu "..." ke spuštění vyhledávání ve slovníku. 
 Pokud je vyhledávání úspěšné, uvidíte seznam stran obsahujících dané klíčové slovo nebo frázi. 
 Dvojitým kliknutím na položku v seznamu otevřete požadovanou stránku ve slovníku. 

 
 
  

 Obecné volby – MetaEditor – Volby       
 

  

Obecné volby 
Slouží ke změně odsazení a tabelace, stejně tak k asistenčním volbám: 

 V menu zvolte "Tools -> Options"; 
 Přepněte do tabulky "General"; 
 Zakřížkujte pole "Auto Indent" k odsazení každého dalšího řádku automaticky podle aktuálního řádku; 
 Zadejte velikost tabelace v poli "Tab size"; 
 Potvrďte volbou "OK". 

Asistent usnadňuje vytváření programu. Můžete použít seznam pro listování "List Names" k dokončení nekompletních jmen prostřednictvím 
volby objektů ze seznamu zabudovaném v MQL4. Položka "Parameter Info" otevírá pomocnou funkci “tooltip”, vyobrazující parametry 
funkcí po jejich vložení.  

Pro úpravu asistenta: 
 Z menu zvolte položku "Tools -> Options"; 
 Přepnutí do tabulky "General"; 
 Zakřížkujte volbu "Auto List Names" k aktivaci seznamu k procházení jmen se zabudovanými objekty po vložení několika 

prvních znaků; 
 Použijte pole "List names after chars" ke vložení počtu znaků, které musíte zadat před otevřením seznamu se jmény a jejich  

zabudovanými objekty; 
 Zakřížkujte pole "Auto Parameter Info" k aktivaci pomocného nástroje “tooltip”, vyobrazujícího parametry funkcí MQL4; 
 Potvrďte volbu "OK". 

 
 
 
  

 Zvýraznění syntaxe – volby funkce MetaEditor        
 

  

Zvýraznění syntaxe 
Pro nastavení funkce zvýraznění syntaxe: 

1. Zvolte z menu položku "Tools -> Options"; 
2. Přepněte do tabulky "Colors"; 
3. Zvolte seznam "Elements" k výběru položky, kterou chcete zvýraznit; 
4. Zvolte barvu fontu v poli "Foreground". Zvolte barvu pozadí v poli "Background". Pokud paleta neobsahuje barvy, které 

potřebujete, můžete použít rozšířenou volbu "More colors" k otevření palety s dalšími barvami; 
5. Opakujte všechny výše uvedené kroky u elementů, které hodláte zvýraznit; 
6. Potvrďte volbou "OK". 

Pozor: Pro obnovu výchozího nastavení zvýraznění všech elementů syntaxí klikněte na položku “Reset All" button.  
 



 
 
  

 Nastavení fontů – Volby funkce MetaEditor       
 

  

Nastavení fontů 
Pro úpravu fontů: 

 Z menu zvolte položku the "Tools -> Font"; 
 Přepněte do tabulky "Font"; 
 Zvolte jméno fontu v poli "Font"; 
 Vložte rozměr fontu v poli "Size"; 
 Zvolte kódování v seznamu "Script"; 
 Potvrďte volbou "OK". 

Poznámka: Tabulka "Font" obsahuje box s náhledem na text se zvoleným nastavením fontů. 
 
 
  

 Nastavení nástrojové lišty – Volby MetaEditor   
 

  

Nastavení nástrojové lišty 

Ve funkci MetaEditor můžete: 
 aktivovat/deaktivovat nástrojovou lištu; 
 Upravit nástrojovou lištu. 

Nástrojovou lištu můžete upravit těmito způsoby:  
 Přidat volby; 
 Odebrat volby; 
 Přesunout volby; 
 Změnit způsob vyobrazení nástrojové lišty; 
 Změnit její rozměr;  
 Přesunout nástrojovou lištu. 

Aktivace/deaktivace nástrojové lišty 
Nástrojová lišta je vyobrazena ve výchozím nastavení. K jejímu zakrytí zvolte z menu položku "View -> Toolbar". 
Poznámka: Nástrojovou lištu můžete zakrýt formou plovoucího okna použitím ikonky   v pravém horním rohu. 

Přesunutí nástrojové lišty 
Nástrojová lišta může být vyobrazena ve dvou režimech: Pevném nebo plovoucím. Pevná nástrojová lišta je umístěna v horním, spodním, 
levém nebo pravém ohraničení okna editoru. Plovoucí nástrojová lišta sestává z titulní lišty a můžete ji umístit kamkoliv do obrazovky. 
Plovoucí nástrojová lišta je umístěna v horní části všech oken a můžete u ní měnit rozměr a polohu.   

Ke změně režimu nástrojové lišty z pevného na plovoucí musíte buď dvakrát kliknout na její okraj nebo kliknou jednou a přetáhnout ji.    

Pro přepnutí nástrojové lišty do plovoucího režimu je třeba na lištu buď dvakrát kliknout nebo ji přetáhnout do polohy, ve které ji chctete 
mít umístěnou a uvolnit tlačítko myši po dosažení změny do požadovaného tvaru  

Změna velikosti a přesun nástrojové lišty 
Nástrojovou lištu můžete pomocí myši přesunout do jakékoliv pozice na  obrazovce. Přesuňte ukazatel dna okraj plovoucí nástrojové lišty 
tak, aby se objevila dvojsměrná šipka a posuňte okraj do požadovaného rozměru.     

Přidání, odebrání a přesun položek 
Přidání voleb:  

1. Zvolte z menu položku "View -> Customize" k otevření dialogového okna "Customizing Toolbar"; 
2. Vyberte položku, kterou si přejete přidat do seznamu pole “Available"; 
3. Vyberte položku, kterou chcete vložit do pole "Selected"; 
4. Klikněte na položku "Insert" nebo dvakrát klikněte na vybranou položku, která se tímto vloží do pole “toolbar” a přesuňte ji z 

pole "Available" do pole "Selected"; 
Pozor:  
Položku můžete rovněž přetáhnout z pole "Available" do "Selected" a umístit tak do nástrojové lišty.  
5. Opakujte kroky 2-4 ke vložení další položky do lišty nástrojů až jsou přiřazeny v nástrojové liště všechny funkce, které 

potřebujete; 



6. Klikněte na volbu "Close". 

Odstranění položky z nástrojové lišty: 
1. Z menu zvolte položku  "View -> Customize" k otevření dialogového okna "Customizing Toolbar"; 
2. Vyberte položku, kterou chcete odstranit z pole "Selected"; 
3. Klikněte na položku "Remove" nebo dvakrát klikněte na vybranou položku v nástrojové liště a přesuňte ji z pole “Selected” do 

pole "Available"; 
4. Opakujte kroky 2-4 až odstraníte všechny položky, které potřebujete; 
5. Klikněte na volbu "Close". 

Pozor: Položku můžete z pole "Selected" do  "Available" přesunout zu nástrojové lišty rovněž ručně. Mimo to můžete za pomocí klávesy  
"Shift" přesunout položku kamkoliv a poté ji upustit bez otevření okna "Customizing Toolbar".  

Přesun položek v rámci nástrojové lišty: 
1. Z menu zvolte položku "View -> Customize" pro otevření dialogového okna "Customizing Toolbar"; 
2. Zvolte položku, kterou si přejete přesunout, v poli "Selected"; 
3. Použijte volby "Up" a "Down" k posunu položek o jednu pozici vlevo nebo vpravo v nástrojové liště a nahoru nebo dolů v poli  

"Selected"; 
4. Opakujte krok step 3 až po umístění položky v požadovaném místě nástrojové lišty; 
5. Opakujte kroky 2-4 až jsou umístěny všechny požadované položky; 
6. Klikněte na volbu "Close". 

Pozor: 
Umístění položky můžete změnit v poli "Selected" a v nástrojové liště pomocí techniky "Drag&Drop". Kromě toho můžete přesunout položku 
pomocí klávesy “Shift" v rámci nástrojové lišty bez otevření okna "Customizing Toolbar".  

Resetování nástrojové lišty 
Pokud resetujete nástrojovou lištu do výchozího nastavení, všechny změny jsou zrušeny. K resetování nástrojové lišty: 

1. V menu zvolte položku "View -> Customize" k otevření dialogového boxu "Customizing Toolbar "; 
2. V menu zvolte položku "Reset" button v dialogovém boxu "Customizing Toolbar"; 
3. Klikněte na volbu  "Close". 


